Temporary slowdown in mail processing

Incident Report for Go Autonomous

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 10:32 CET

Update

We are continuing to monitor for any further issues.
Posted Mar 10, 2025 - 10:06 CET

Monitoring

We have identified the issue and have released a fix. Mails that have been stuck in "AI Processing" will now transition to "Ready for Review" in order received.
Posted Mar 10, 2025 - 10:05 CET

Investigating

We are currently investigating this issue.
Posted Mar 10, 2025 - 09:44 CET
This incident affected: API - Orchestrator.