Delays in email processing

Incident Report for Go Autonomous

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 18:53 CET

Monitoring

We increased resources and monitoring to ensure that mail processing is fully operational again.
Posted Nov 17, 2025 - 17:22 CET

Investigating

We are experiencing delays in processing emails, which may affect some inboxes. We are investigating the matter and increasing our resource allocation.
Posted Nov 17, 2025 - 16:39 CET
This incident affected: API - Orchestrator.