Delays in email processing

Incident Report for Go Autonomous

Resolved

After monitoring the health of our processing queues for some time, we consider this issue resolved.
Posted Nov 19, 2025 - 14:47 CET

Monitoring

The queue has finally stabilized, and mail processing is back to normal. We are monitoring the situation to prevent the slowdown from happening again.
Posted Nov 18, 2025 - 17:43 CET

Identified

We are actively investigating the degraded performance for selected inboxes.
Posted Nov 18, 2025 - 12:58 CET

Monitoring

We increased resources and monitoring to ensure that mail processing is fully operational again.
Posted Nov 18, 2025 - 12:11 CET

Investigating

We are experiencing delays in processing emails, which may affect some inboxes. We are investigating the matter and increasing our resource allocation.
Posted Nov 18, 2025 - 11:53 CET
This incident affected: API - Orchestrator.