We will be undergoing scheduled maintenance during this time.
Posted Apr 28, 2026 - 07:38 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 27, 2026 - 14:37 CEST
Scheduled
We are upgrading our cloud authentication service. During the maintenance phase, users will not be able to log into our platform for about 30 minutes. Mail processing is unaffected.
Posted Apr 27, 2026 - 13:49 CEST
This scheduled maintenance affects: Web - Frontend.